blog.pragmaticengineer.com
3 votes roger — 3 votes, 1 commentsSource

Yeah, some good points. One minor nit pick:

But “bad code” is a lazy expression.

I would call it ambiguous instead of lazy since lazy means something.